webpを使いたいです

VWSとは フォーラム バグ報告と提案 webpを使いたいです

webpを使いたいです

タグ: 

  • このトピックには10件の返信、2人の参加者があり、最後にmomoにより5ヶ月前に更新されました。
11件の投稿を表示中 - 1 - 11件目 (全11件中)
  • 投稿者
    投稿
  • #51089

    momo
    参加者

    カードブロックの画像がGoogleスピードテストで新フォーマットにすべきとの警告が出ているため、webp形式の画像を入れようとしたのですが、添付写真のようなエラーで入れることが出来ませんでした。
    WordPressのメディアとしては既にアップロードしてあるので、画像ブロックには入れることが可能なのですが、カードブロックにはだめでした。
    Safariもwebp対応したとのことで、徐々にwebpに差し替えたいと思っておりますので、対応をお願いしたいです。

    Lightning G3βバージョン: 14.0.9
    Lightning G3 Pro Unit バージョン 0.1.4

    Attachments:
    You must be logged in to view attached files.

    該当URL : https://*********

    ※該当URLはフォーラムライセンスが有効のユーザーにのみ表示されます

    #51096

    参考情報です。

    Lightning G3βバージョン: 14.0.9
    Lightning G3 Pro Unit バージョン 0.1.4

    同じ環境ですが、
    カードブロックのカードアイテムの画像に WebP 画像を設定できています。

    カードブロックに WebP 画像を使用

    カードブロックを作り直す
    プラグインを停止する
    のようなことをすれば原因が絞り込めるかもしれません。

    • この返信は5ヶ月前に対馬 俊彦が編集しました。
    #51109

    momo
    参加者

    対馬様
    本当にいつもありがとうございます。
    私も違うカードブロックでも試して見た結果、両方ともダメだったので投稿したのですが、しかし、対馬様が使えると言う事は、Lightningの制限は無さそうですね。

    思えば、わたしのカードブロックは数ヶ月前に作って再利用ブロックに入れて時々愛用してた古いアイテムです。
    最新の環境と何か微妙に相性があるとか、何かあるやも知れず。

    今は実験出来ませんが、また、少し試して見ます。
    まだ、私の方では未解決なので、このまま未解決にしますが、おそらく私個人の事だと分かりましたので、ベストアンサーは設定はこの時点でさせて頂きました。

    #51113

    momo
    参加者

    新規にテストページを作成し、その真っ新な固定ページにカードブロックを追加して実験したのですが結果はダメでした。
    どうやら私の環境問題(プラグインか何かが原因)と言う事ですね。

    念のために他の問題要素として、私がwebp画像を作成したアプリの問題である可能性も潰すため、ネット上のwebp変換サイトを使ってのwebp画像もカードブロックに入れてみたのですが、そちらのwebp画像も同様のエラーでした。

    変換アプリも原因でないとすれば、この結論は、おそらく私の環境固有で確定ですね。

    ただ、私の環境でもカードブロック以外の普通の画像ブロックやアイキャッチ画像に関しては、webpが使えているので、カードブロックに対してだけ干渉する環境問題なのかも知れません。

    そうなるとLightningのカードブロック限定での問題の可能性があるので、プラグイン側での対応があまり期待できないですね。
    今入れているプラグインはスピード重視の観点から最小限にしているので、これ以上は減らしたくないので、カードブロックの利用を一旦諦めたいと思います。

    あるいはカードブロックにはwebpを諦めるか。

    私以外の皆様がwebpとカードブロックの相性問題が報告されない場合は、ベクトル様の対応も期待できないと思うので、この先は私個人の問題として個人的に試行錯誤したいと思います。

    今のところ思う付くのは

    1、webp優先してカードブロックの断念
    2、カードブロックを優先してjpeg利用
    3、ダメもとでプラグイン開発元に相談(まず原因特定が先ですけど)
    4、その他、思いついたら更なる実験

    何か進展があったら、また報告を追加します。

    今回は特に対馬様、お世話になりました。

    #51115

    momo
    参加者

    何も進展ではないのですが追記します。

    カードブロックの代わりに「PRブロック」に画像を入れると言う逃げ道はどうか?
    と思ったのですが、やっぱり同じエラーでした。

    #51117

    まず原因特定が先ですけど

    ・プラグインをひとつずつ無効化してみる
    ・ブラウザのキャッシュを削除する
    などが一般的な作業ですが、デベロッパーツールのコンソールからなにか情報が得られるかもしれません。

    参考ページ:https://kt-life.net/error-g-preview/

    #51119

    momo
    参加者

    ###この投稿は対馬様のアドバイスとすれ違いのタイミングで投稿されたものです。

    ヒントが見つかりました。
    もし、このヒントからベクトル様で何か作りの中で思い当たる節があったら嬉しいのですが。

    投稿リストブロックを作成

    投稿リストブロックなので、リスト表示にはアイキャッチ画像が表されます。
    そのアイキャッチ画像をwebpで指定してあれば
    投稿リストブロックには、問題なくwebp画像が表示されました。

    結果だけ見たら、カードブロックと酷似するデザインですが、投稿リストブロックであれば、webpが表示可能と言うことがわかりました。
    これがヒントとなり、簡単に解決策があったら良いのですが、やっぱり私固有の問題であったらベクトル様にもヒントにもならないかもしれません。

    まずは、せっかくの発見した逃げ道なので、投稿リストブロックで代用する方向を模索したいと思います。
    ただ、投稿リストブロックとカードブロックは結果的に非常に似てるので、内部構造がそっくりなら、将来、投稿リストブロックもエラーが出る恐れがありそうで、ちょっと迷ってます。

    • この返信は5ヶ月前にmomoが編集しました。
    • この返信は5ヶ月前にmomoが編集しました。理由: 冒頭に追記###この投稿は対馬様のアドバイスとすれ違いのタイミングで投稿されたものです。
    #51122

    momo
    参加者

    対馬様

    すれ違いの投稿でした。
    デベロッパーツールの参考事例をありがとうございます。
    本来はプラグイン停止が基本であることは承知してますが、稼働サイトにてちょっと躊躇もあり、代替案をご提示頂いたご配慮に感謝します。

    早速、真似してみたのですが、画像設定時にブロックエディターでエラーが出た際に

    デベロッパーツールで!マークが見当たらず、エディター画面とデベロッパーツールの表示でエラーブロックとの位置合わせをしようとしたのですが、エラーとなるブロックが特定できずでした。
    デベロッパーツールのどこを触れても、左側のブロックエディター画面では画面全域がハイライトされてしまって素人目にエラー箇所の情報が吸い出せませんでした。
    ツールのソースでネストを開いてもダメでした。

    そこで、実験していた固定ページを一旦公開モードに切り替えて、皆様に見ていただこうとしたのですが、今度はエラーが出たページは2度と編集画面が表示されない状況でした。

    何度か繰り返し、同じ実験を作り直したのですが、どうやら、今回のwebp画像を入れてのエラーになると、その固定ページは、以後、編集画面に入ると画面が真っ白で、編集が出来ない可能性が高いことが分かりました。
    稼働中サイトの稼働中のページがそうならなかったのは幸いでした。

    そんな状況なので、本当に大事なページで、この画面真っ白が出ては私の手に負えない事故になってしまうので、無理してwebpの早期導入はやめたほうが良いのかもしれません。

    webp導入を進めたい気持ちは今も残るのですが、WordPress自体も、現状、アップロードする時点でプラグインかFTPと言う状況ですので、WordPressが正式にサポートして、webpユーザーが増えてきた頃には、原因がプラグインであれ、私の環境であれ、自然と問題が解決する日が来るかもしれません。

    対馬様には、ここまでご尽力いただいたのですが、これ以上はちょっと私のレベルを超えることになりそうなので、終了したいと思います。

    最後に、プラグインの停止による特定ですが、今残っているプラグインは、これ以上は減らせないというか減らしたくないプラグインなので、原因が判明しても結果的に逃げようがない事。
    それでも原因を絞れるメリットがあるのですが、現在、稼働中サイトで実験中なので、大事なプラグインを停止するのがちょっと気になるので、このプラグインの停止を伴う実験は、後日、別な実験サイトに環境をコピーしてから行います。

    プラグインが特定できたら、もしかしたら活路もあるやもしれませんが、私自身が即プラグイン停止できない以上は、そしてデベロッパーツールが使いこなせない状態では、一旦、終了モードで致し方ないと思いました。

    対馬様、お騒がせしました。

    一旦休憩で、また、サイトコピー後の実験で情報があったら継続投稿させていただきます。

    #51126

    momo
    参加者

    やっぱり気になって実験用サイトにてプラグインを全停止して、ベクトル様の純正のみ残して実験するも
    結果が同じでした。

    こうなると他社プラグインに問題もなく、私のコンテンツの問題なのか?
    完全に私個人の問題になってしまったのかもしれません。

    ちなみに現在稼働中のプラグインは添付ファイルです。

    個人的な環境問題だと決まってしまうと、私の力ではどうしようもないので、正直なところ万策尽きたと言うところです。
    webpは断念を視野に入れてます。

    Attachments:
    You must be logged in to view attached files.
    #51133

    momo
    参加者

    素人として出来る範囲の暫定対策を実施しましたので報告します。

    とりあえず、当初webpが設定出来ない問題を報告させて頂いた箇所は、カードブロックを廃止して、PRブロックに置き換え。
    そしてPRブロックには画像を採用せず、アイコンのままにして、Googleスピードテストにおけるwebpを促する警告を止めました。

    何故にカードブロックやPRブロックで、webpを指定出来ない問題の原因究明は断念しましたが、問題は回避されました。

    将来、再びカードブロックを採用したい時、その時点でも、まだ、webpでエラーが出てしまう時は、改めて投稿させて頂きます。

    このスレッドは個人的には解決済みにしても良いのですが、本当は原因不明で解決済みは嘘になるので、とりあえず解決済みボタンを押さずに置きます。

    もし、ベクトル様にて、フォーラム管理の上で邪魔になるようでしたら解決済みに状態遷移して頂いて構いません。

    #51239

    momo
    参加者

    webpをあれからも使ってみていたのですが、まだ時期早尚な感が出てきました。
    達人、または、プラグインを使いこなせる人は良いとは思うのですが、自分の技量では時期早尚でしたのでご報告です。

    時期早尚と思った理由ですが、投稿時にアイキャッチ画像をwebpで設定すると、アイキャッチ画像設定画面の中で前後に画像がはみ出してしまうようです。表現が変ですが、実際にwebpをアイキャッチに設定すると一目瞭然です。

    故に、その下にある、概要欄など付近の項目を修正トしたいと思っても、パソコンの大画面なら画像に潰されずに概要欄がかろうじて表示されてますが、iPhoneでは、概要欄がアイキャッチ画像のはみ出した状態の下になって編集不能でした。

    私の場合はwebpに関してはMacのアプリを使って作成していたので、投稿の編集もMacの大画面だったので、この問題に気付くのが遅くなりました。
    たまたま投稿した後で出先でiPhoneで概要欄を修正したいと思った時に作業不能となって気がつきました。

    この問題はWordPress本体がwebpに対応するまで治らないと思うので、私もそれまではwebpの多用は避けて、速度を有利にしたいトップページくらいに抑えようと思ってます。

    このスレッドで報告した元々の課題も、もしかしたらWordPress自体がwebp対応したら治るかもしれませんし。
    (結局は私の環境ではベクトル製以外のプラグインを止めても治らない状態だったので、WordPress対応で同時に治るのを期待してます)

    • この返信は5ヶ月前にmomoが編集しました。理由: 少し文章の訂正
11件の投稿を表示中 - 1 - 11件目 (全11件中)
  • このトピックに返信するにはログインが必要です。