[ 質問者返信待ち ] Lightning G3 Pro Unitバージョン0.23.3にアップデートするとエラーになる

VWSとは フォーラム バグ報告と提案 [ 質問者返信待ち ] Lightning G3 Pro Unitバージョン0.23.3にアップデートするとエラーになる

[ 質問者返信待ち ] Lightning G3 Pro Unitバージョン0.23.3にアップデートするとエラーになる

9件の投稿を表示中 - 1 - 9件目 (全9件中)
  • 投稿者
    投稿
  • #71846

    assist
    参加者

    ■ WordPress のバージョン
    6.11

    ■ テーマ・プラグインは全て最新版で確認してください。
    確認しました。

    ■ 子テーマをご利用の場合は親テーマに変更して症状が改善するか確認してください。
    確認しました。

    ■ テーマの種類
    Lightning ( G3 ) + Lightning G3 Pro Unit

    ■ テーマのバージョン
    15.1.4

    ■ Pro Unit のバージョン
    0.23.3

    ■ スキンの種類
    Origin III

    ■ 関連しそうなプラグインを一つづつ停止して症状が改善するか確認してください。
    確認しました。

    ■ プラグインの種類・バージョン
    Lightning G3 Pro Unit0.23.3

    ■ 期待する動作
    アップデートするとエラー表示しないように

    ■ 自分で試した事
    他のプラグインを無効化したりテーマーを入れ替えてみたりしても改善しませんでした

    ■ 症状が発生するブラウザ
    chrome

    ■ 実際の症状
    Lightning G3 Pro Unit0.23.2から0.23.3にアップデートするとエラーとなり、lightning-g3-pro-unit.php ファイルの 41 行目で発生しました。
    となります。

    #71850

    石川@Vektor,Inc.
    キーマスター

    確認しましたが弊社環境では発生しませんでした。
    以下ご確認ください。

    * サーバーの混雑による一時的なものかもしれませんので、改めて状況ご確認ください。
    * 「エラーとなり、lightning-g3-pro-unit.php ファイルの 41 行目で発生しました。」とはどのページで表示されますか?
    * 上記メッセージが表示される以外に、有効化できない、サイトが落ちる などどんな症状が発生していますか?
    * サーバーのPHPのバージョンはいくつでしょうか?
    * 外部へアクセスするのに関してサーバー側で何か制限がかかっていたりしないかどうか?

    よろしくお願いいたします。

    #71859

    assist
    参加者

    お世話になります。
    PHPのバージョンは7.4.33になります。
    8.0.25に変更してみましたが同じでした。

    プラグインの画面から更新をすると下記画面となり戻らなくなってしまいます。

    Fatal error: Uncaught Error: Class ‘Puc_v4_Factory’ not found in /home/xs777741/xs777741.xsrv.jp/public_html/wp-content/plugins/lightning-g3-pro-unit/lightning-g3-pro-unit.php:41 Stack trace: #0 /home/xs777741/xs777741.xsrv.jp/public_html/wp-includes/class-wp-hook.php(308): {closure}(”) #1 /home/xs777741/xs777741.xsrv.jp/public_html/wp-includes/class-wp-hook.php(332): WP_Hook->apply_filters(NULL, Array) #2 /home/xs777741/xs777741.xsrv.jp/public_html/wp-includes/plugin.php(517): WP_Hook->do_action(Array) #3 /home/xs777741/xs777741.xsrv.jp/public_html/wp-settings.php(595): do_action(‘after_setup_the…’) #4 /home/xs777741/xs777741.xsrv.jp/public_html/wp-config.php(99): require_once(‘/home/xs777741/…’) #5 /home/xs777741/xs777741.xsrv.jp/public_html/wp-load.php(50): require_once(‘/home/xs777741/…’) #6 /home/xs777741/xs777741.xsrv.jp/public_html/wp-admin/admin.php(34): require_once(‘/home/xs777741/…’) #7 /home/xs777741/xs777741.xsrv.jp/public_html/wp-admin/about.php(10): require_once(‘/home/xs777741/…’) #8 {main} th in /home/xs777741/xs777741.xsrv.jp/public_html/wp-content/plugins/lightning-g3-pro-unit/lightning-g3-pro-unit.php on line 41
    このサイトで重大なエラーが発生しました。対応手順については、サイト管理者のメール受信ボックスを確認してください。

    宜しくお願い致します

    #71867

    nizatoy
    参加者

    当方も、更新した結果、下記のようにエラーが表示され、管理画面に入れなくなりました。
    通常の公開済みページは、正常動作します。

    ========================

    Fatal error: Class ‘Puc_v4_Factory’ not found in /home/vps******/*****.com/**/wp-content/plugins/lightning-g3-pro-unit/lightning-g3-pro-unit.php on line 41
    このサイトで重大なエラーが発生しました。対応手順については、サイト管理者のメール受信ボックスを確認してください。

    WordPress のトラブルシューティングについてはこちらをご覧ください。

    ========================

    #71868

    nizatoy
    参加者

    下記、該当プログラムの該当箇所あたりのソースですが・・・

    // PHPUnit用に global に入れたが現状 PHPUnit 上でどうも正常に受け取れていない .

    というコメントが記述されていますが、関係ありますか?

    =========================================

    if ( is_admin() ) {
    // PHPUnit用に global に入れたが現状 PHPUnit 上でどうも正常に受け取れていない .
    global $ltg3pro_update_checker;
    $ltg3pro_update_checker = Puc_v4_Factory::buildUpdateChecker(
    https://vws.vektor-inc.co.jp/updates/?action=get_metadata&slug=lightning-g3-pro-unit’,
    __FILE__,
    ‘lightning-g3-pro-unit’
    );

    ltg3pro_check_update();
    }

    ====================================

    #71869

    nizatoy
    参加者

    取り急ぎ、wp-content/plugins/lightning-g3-pro-unit のフォルダ名をリネーム( 例:: lightning-g3-pro-unit-tr )して無効にしたところ、管理画面に正常にログイン出来ました。 当方の公開ページの表示は、Lightningバージョン: 15.1.3 に入れ替わり、とりあえず動作しているようです。 ※ Lightning の更新メッセージは表示されていますが、不安なので更新していません。

    #71883

    Vektor,Inc
    キーマスター

    確認中でございます、ご不便おかけして申し訳ございません。

    #71889

    石川@Vektor,Inc.
    キーマスター

    発生する環境と発生しない環境があり、正確な原因は引き続き調査中ですが、
    取り急ぎ該当部分のライブラリをアップデートしたバージョン 0.23.4 を配信いたしました。

    ダウンロード・アップデートの上ご確認くださいませn。

    ご迷惑おかけして恐れ入りますがよろしくお願いいたします。

    #71898

    石川@Vektor,Inc.
    キーマスター

    > nizatoy 様

    // PHPUnit用に global に入れたが現状 PHPUnit 上でどうも正常に受け取れていない .
    というコメントが記述されていますが、関係ありますか?

    この内容については関係ありませんが、アップデート回りの扱いでバグがあったので 0.23.4 にて修正版配信いたしました。
    ご迷惑おかけして大変申し訳ございません。

9件の投稿を表示中 - 1 - 9件目 (全9件中)
  • このトピックに返信するにはログインが必要です。