[ 解決済 ] CTAに特定のブロックのみ挿入できない

VWSとは フォーラム Lightning [ 解決済 ] CTAに特定のブロックのみ挿入できない

[ 解決済 ] CTAに特定のブロックのみ挿入できない

10件の投稿を表示中 - 1 - 10件目 (全10件中)
  • 投稿者
    投稿
  • #77092

    ■ WordPress のバージョン
    6.2.2

    ■ テーマ・プラグインは全て最新版で確認してください。
    確認しました。

    ■ 子テーマをご利用の場合は親テーマに変更して症状が改善するか確認してください。
    確認しました。

    ■ テーマの種類
    Lightning ( G3 ) + Lightning G3 Pro Unit

    ■ テーマのバージョン
    15.9.5

    ■ Pro Unit のバージョン
    0.25.1

    ■ スキンの種類
    Origin III

    ■ 関連しそうなプラグインを一つづつ停止して症状が改善するか確認してください。
    確認しました。

    ■ 期待する動作
    CTAにCall to Actionの「資料請求とお問い合わせボタン」や「電話ボタンとメールボタンのお問い合わせゴーストボタン」を挿入したい。

    ■ 自分で試した事
    プラグインの全停止→動作で確認
    キャッシュクリア
    CTAページを複数作成して、各ブロックを挿入、保存を行ってみました。

    ■ 症状が発生するブラウザ
    Chrome

    ■ 実際の症状
    CTAのページを作成していて、特定のパターン
    「資料請求とお問い合わせボタン」
    「PRコンテンツ全幅」
    「PRコンテンツFree全幅」
    「電話ボタンとメールボタンのお問い合わせ」
    「資料ダウンロード」
    「電話ボタンとメールボタンのお問い合わせゴーストボタン」

    これらを挿入すると、
    更新に失敗しました。 返答が正しい JSON レスポンスではありません。
    が返ってきます。

    しかしカラムバナーを先に入れた後に各パターンを配置する時にはエラーは出ず保存されます。
    わかりづらいので、画像を添付いたします。

    1 単独でCTAブロック挿入→エラー
    2 カバーブロックを挿入後、CTAパターンブロックを挿入→エラー
    3 カラムバナーブロック挿入後、CTAパターンブロックを挿入→正常終了

    単独でブロックを配置したいのですが、このような症状になってしまうため、対策があればご教授いただければ幸いです。

    Attachments:
    You must be logged in to view attached files.
    #77107

    私の環境で確認する限り特に同様のエラーは発生しませんでした。

    投稿タイプ「CTA」に 新規挿入で パターン > Call To Action > 資料請求とお問い合わせボタン を挿入 という事ですよね?

    CTA以外の投稿タイプには貼れますか?

    #77110

    固定ページ、及び投稿いずれも試してみましたが、問題なく挿入、保存ができます。
    CTAのみがそのような状態です。

    #77132

    うなこ
    モデレーター

    こちらのパターンをCTAにコピペした場合は、エラーがでますか?

    CTA_PR コンテンツ 全幅

    • この返信は11ヶ月、 2週前にうなこが編集しました。
    #77143

    これだとエラーにはならず、保存されます。

    余談なのですが、使用しているサーバはLolipopで、昨日Lolipopの別サーバで操作をする前に、WAFを切ってWPをインストールし、CTAを操作してみたところ、普通に更新されました。
    しかしWAFをONにするとエラーになるため、これか?と思いWAFを再びOFFにしてキャッシュを削除後、操作をしてみたのですが、症状は改善されないままでした。

    Attachments:
    You must be logged in to view attached files.
    #77161

    ご報告申し上げます。
    Xserverとさくらサーバで同様の操作を行ってみたのですが、エラーは出ませんでした。
    どうやらLolipopに特化した問題のようです。

    #77165

    うなこ
    モデレーター

    どうやらLolipopに特化した問題のようです。

    報告ありがとうございます🙇‍♂️
    こちらでも何か分かりましたら返信いたします。

    —–

    これだとエラーにはならず、保存されます。

    添付画像をみましたところ、ページのリンクを埋め込んでいる状態のようですので、以下を試していただいても良いでしょうか?

    • このページのコンテンツ下にある「このパターンをコピーする」ボタンをクリックしてコピーします
    • ご自身のサイトのCTAの投稿に貼り付け(Ctrl + V)てください

    そうしますと、エラーは出ますでしょうか。

    おそらく、VK Block Patterns デフォルトパターンのパターンでエラーが出るのではないかなと思いましたので、上記の質問をさせていただきました。

    もしエラーが出ないようでしたら、VK パターンライブラリ内にもCTAのパターンがたくさんありますので、VK パターンライブラリのユーザー登録がお済みでしたら、お気に入り機能を利用して、お気に入りパターンをご自身のWordPressの編集画面に直接読み込んで利用できます。この方法でしたらエラーが発生しないのではと思いましたが、、どうでしょう、、?

    • この返信は11ヶ月、 2週前にうなこが編集しました。
    • この返信は11ヶ月、 2週前にうなこが編集しました。
    • この返信は11ヶ月、 2週前にうなこが編集しました。
    Attachments:
    You must be logged in to view attached files.
    #77178

    うなこ様、お返事ありがとうございます(←これは書いてもよろしいのですね。大変失礼いたしました。)

    コピペでも同様のエラーでした。

    本当に不思議なのは、なぜか「カラムバナー」を挿入した時のみエラーがなくなるという点です。
    これは順番が異なっても同様でたとえば、
    先にCTAのブロック→エラー→カラムバナー挿入→OK
    その状態から
    カラムバナーブロックのみ削除→保存→NG
    または
    カラムバナーブロックのカバーを1つでも削除→保存→NG
    と言った感じです。

    本当によくわかりません。

    #77179

    どうやらLolipopに特化した問題のようです。

    だとすると、
    ロリポップ!アクセラレータを無効にして試してみたら、なにか変わるかもしれません。

    #77218

    対馬様、ヒントありがとうございました。
    おかげさまでどうやら解決できたようです。

    1.アクセラレータON WAF ON
    エラー

    2.アクセラレータOFF WAF ON
    エラー

    3.アクセラレータ OFF WAF OFF
    エラー

    4.アクセラレータ ON WAF OFF
    OK

    私自身が慌てすぎていたのか、WAFをONしてから一定時間が経過しないうちに触ったのが原因のようで
    WAFをOFFにしてから1時間ほど放置し、CTAのブロックパターン挿入をやってみたところOKでした。
    逆に、アクセラレータOFF WAF OFFでNGだったのが意外でしたが(これは今後も追及してみます)
    いずれにせよう、解決することができました。

    ご助言いただいた皆様、ありがとうございました。

10件の投稿を表示中 - 1 - 10件目 (全10件中)
  • このトピックに返信するにはログインが必要です。