VWSとは フォーラム Lightning [ 解決済 ] モバイル時にウィジェットが非表示になる時

[ 解決済 ] モバイル時にウィジェットが非表示になる時

  • このトピックには9件の返信、2人の参加者があり、最後にmomoにより1ヶ月前に更新されました。
10件の投稿を表示中 - 1 - 10件目 (全10件中)
  • 投稿者
    投稿
  • #43483

    momo
    参加者

    物凄く初歩的なことを今更聞くのか?
    と我ながら思うのですが、すっかり忘れてしまったみたいです。

    添付の写真はiPhoneと iPad横画面の写真です。
    横長の画面では、黄色の丸で囲んだ問い合わせウィジェットが表示されますが、iPhoneの狭い画面では黄色の丸で囲んだ通りに非表示になります。

    何か非表示にしてる?とブロックの設定を見ても分からず。どこでしたっけ?(笑)

    質問させて頂きました。

    Attachments:
    You must be logged in to view attached files.

    該当URL : https://*********

    ※該当URLはフォーラムライセンスが有効のユーザーにのみ表示されます

    #43486

    momo
    参加者

    今、手元にiPhone、iPadしかないのですが、もしかしたら、ボタン3段のブロックをグループ化して、非表示にしてあるのか?

    その確認が出来てません。

    Macでその点を確認してみます。

    とりあえず、ボタン個別には非表示にしてないのはiPhoneでも確認は出来てますが、グループ化してないか?

    Macで確認してみます。

    #43487

    momo
    参加者

    Macで見ても、特に、三段のボタンをグループ化しての非表示設定とかしてない様な感じでした。
    やっぱりわからないです。

    #43489

    うなこ
    モデレーター

    ボタン個別で非表示設定がされているようでした。
    該当の固定ページのボタンを選択して頂き、横に非表示設定がでますので、
    そちらから設定お願いいたします。

    Attachments:
    You must be logged in to view attached files.
    #43492

    momo
    参加者

    うなこさん、ありがとうございます。
    その点は確認してある(つもり)なのですが、私の環境では非表示にはなってないように見えるのです。
    添付の写真が、1番上のボタンブロックの様子です。

    Attachments:
    You must be logged in to view attached files.
    #43497

    うなこ
    モデレーター

    ほんとですね…

    一度、非表示設定の一番上の
    非表示 ( 画面サイズ : all )をONにしてからOFFに戻していただき、
    もう一度更新ボタンを押していただいても変わらないでしょうか?

    変わらない場合は、お手数ですがボタンをもう一つ設置しても同じように非表示になってしまいますか?

    #43502

    momo
    参加者

    うなこさんへ
    結論から先に書くと解決です。

    解決手順は、成功と失敗の違いが若干妙な具合でした。
    いろいろやったので、参考までに。

    手順1:

    >非表示 ( 画面サイズ : all )をONにしてからOFFに戻していただき、
    もう一度更新ボタンを押していただいても変わらないでしょうか?

    これは効果が出ませんでした。キャッシュも考えて少し時間をおいたり、他のブラウザで確認してもやっぱりダメでした。

    手順2:

    非表示を一番上だけじゃなく、縦に全部のスイッチでONにして、更新する。
    また編集モードに入って、全てのスイッチをOFFにして更新する。

    これも効果なし。

    手順3:ボタンを新規で作り直す

    解決しました。

    ついでの実験ですが

    手順4:非表示を全てのスイッチでONにして更新する。
    更に、一旦、編集画面から通常の表示画面にする。
    そして再び編集画面に戻って、非表示スイッチをOFFに戻して更新する。

    これは成功でした。

    手順3のボタンの作り直しは、何かのゴミが消えて良いのかな?と感じるのですが
    手順4は、ブラウザの編集状態から表示画面に一度切り替えただけで、元の手順2も更新ボタンを押しているのでセーブしているはずなのに、手順2と手順4で結果が違うのは不思議でした。

    一応、ご参考になればと、やったことを全て記載したのですが、結論的には、ボタンを作り直すのが確実で正解だったみたいです。
    結果オーライではありますが、知らない内に、妙な具合になってしまうのが、ここだけの偶然の問題なのか?
    他の場所も知らぬ間に非表示設定が見えないのに、ONだったら嫌だなあと、多少薄気味悪い感じが残ります。

    • この返信は1ヶ月前にmomoが編集しました。理由: 冒頭に少し追記
    • この返信は1ヶ月前にmomoが編集しました。
    #43505

    momo
    参加者

    とりあえず、気になった箇所の問題は解決したので、アドバイスをありがとうございました。

    #43507

    うなこ
    モデレーター

    そうですね…ちょっと気になりますね。

    もし覚えていれば教えていただきたいのですが
    こちらのボタンは既存であったボタンを複製して作成したものでしたか?

    #43509

    momo
    参加者

    ご質問の意味が、掴めないのですが
    今日、行ったボタン作り直しの部分で確認でしょうか?

    既存ボタン(非表示の問題発生中だった)のコピーなのか?
    完全に新規で作り直したボタンか?

    と言う意味だとすれば、
    この回答は後者で、完全に新規作成したボタンです。
    ただし、文字の前後のアイコンに関しては、探し直すのも面倒なので、コピペしました。

10件の投稿を表示中 - 1 - 10件目 (全10件中)
  • このトピックに返信するにはログインが必要です。