VWSとは フォーラム Lightning [ 解決済 ] 追加CSSで書いたCSSがきかなくなる現象

[ 解決済 ] 追加CSSで書いたCSSがきかなくなる現象

  • このトピックには17件の返信、3人の参加者があり、最後にかつおにより1ヶ月、 2週前に更新されました。
15件の投稿を表示中 - 1 - 15件目 (全18件中)
  • 投稿者
    投稿
  • #45542

    かつお
    参加者

    いつもお世話になります。
    ワードプレス本体テーマが本日5.6にバージョンアップしました
    そこで、テストサイトで、バージョンアップすると、カスタマイズ→追加CSSでいままで反映していたものが、反映されなくなりました。
    exunitのCSSカスタマイズをつかうと反映されるのですが、できれば追加CSSで対応したいのですが、
    良い方法はありますか
    本体は現在wp-configのほうで自動アップデートを止めました。
    よろしくお願いします

    ちなみにすべてというわけではなく、一部です

    #45550

    うなこ
    モデレーター

    わたしのWP5.6の環境では、カスタマイズの追加CSSに記述したCSSは効いているようでした。

    ちなみにすべてというわけではなく、一部です

    こちらは、一部の追加CSSに記述したcssが効かないということでしょうか。
    もし差し支えなければ、追加したCSSを添付できますか…?

    #45553

    かつお
    参加者

    ご連絡ありがとうございます。
    ちなみになんですが、追加ではなく、そもそも反映していたものが、反映されなくなったということです。
    アニメーションの中にいれたhtmlで入力した箇所のCSSが反映しなくなったということです

    #45565

    うなこ
    モデレーター

    症状を私の環境で再現させたいため、詳しくお聞きしてもいいでしょうか。

    アニメーションの中にいれたhtmlで入力した箇所のCSSが反映しなくなったということです

    アニメーションブロックを配置して、図のように「HTMLに変換」をして、その中に独自でCSSを入れたということでしょうか?

    Attachments:
    You must be logged in to view attached files.
    #45583

    かつお
    参加者

    いえ、そうではなくて
    アニメーションブロックの中にカラムを設定し、そのカラムの中をHTMLで書いているという方法です

    #45611

    かつお
    参加者

    画像を添付します
    1、5.6前 CSSがきいている
    2、5.6後 追加CSSの一部がきかなくなる
    3、5.6後 exunitのcssカスタマイズを使うと反映されると順序です
    ご確認おねがいします

    Attachments:
    You must be logged in to view attached files.
    #45616

    石川@Vektor,Inc.
    キーマスター

    WordPress本体の機能である 追加CSS の出力順に変更があったのかなと思います。

    該当URLと 追加CSS に貼り付けてあった追加のCSSを貼れますか?

    #45626

    かつお
    参加者

    ありがとうございます。
    できれば個別対応をさせていただければと思います。
    もちろん、ある程度解決出来たら、ここでシェアはしたいとおもっています

    プライベートチケットを先月からご契約させていただいているのですが、今月はまだ使えないようなので

    #45655

    石川@Vektor,Inc.
    キーマスター

    5.6前後での追加CSSとExUnitのCSSとの出力状況の関係性は僕の環境ではかわりありませんでした。
    その他調査中ですので追ってまた状況書き込みいたします。

    #45657

    石川@Vektor,Inc.
    キーマスター

    5.6でおかしくなったのはテストサイトでしょうか?
    本番サイトでしょうか?
    テストサイトと本番サイトが違うようでしたら一度テストサイトで不具合が発生している状態にしてみてください。

    #45659

    うなこ
    モデレーター

    かつおさん

    本番で稼働中らしきサイトを見つけまして検証ツールで確認しましたところ、
    今現在は カスタマイズ→追加CSS に追加されていますか?
    といいますのも検証ツールで確認したところ、カスタマイズの追加CSSから出力されているようでした。

    上記のこともふまえまして、カスタマイズの追加CSS のcssは正常に効いているように見えました。

    ちょっと気になるところとしては .areaw のところの閉じタグがちょっとおかしいところがありましたので
    .areawの個所を以下のものに変更していただいてもいいでしょうか。

    .areaw{
    background-color:#fff;
    padding:10px 20px 0;
    display:block;
    border-radius:15px;
    border:3px solid #3B3B3B;
    width:100%!important;
    margin-left:auto;
    margin-right:auto;
    padding-bottom:0;
    margin-bottom:0;
    }

    かつおさんの環境でまだ正常に表示されていないようでしたらお知らせください。

    • この返信は1ヶ月、 2週前にうなこが編集しました。
    #45661

    かつお
    参加者

    石川様
    ありがとうございます。
    こちらは、テストサイトというか予備サイトになっています
    本サイトは現在、自動でバージョンアップならないようにしています。
    解決してからにしようと思っております。

    うなこさま
    ありがとうございます
    再度確認しましたが、昨日の画像通りでの記載になっております。
    ご指摘部分はかえてそれだけをexunitから追加CSSに転記して表示させましたが
    結果としてはその箇所だけだめになりました

    Attachments:
    You must be logged in to view attached files.
    #45664

    石川@Vektor,Inc.
    キーマスター

    直接確認したいのでテストサイトの方を症状の出ている状態にしていただけますでしょうか?

    #45670

    かつお
    参加者

    先ほどお見せしたのは画像ページの一部分でした
    このページのものを追加CSSに保存しました。

    よろしくお願いいたします。

    #45673

    石川@Vektor,Inc.
    キーマスター

    ありがとうございます。確認の上改めて返信いたします。

15件の投稿を表示中 - 1 - 15件目 (全18件中)
  • このトピックに返信するにはログインが必要です。