VWSとは フォーラム VK Blocks・Pro [ 解決済 ] 画像表示について

[ 解決済 ] 画像表示について

10件の投稿を表示中 - 1 - 10件目 (全10件中)
  • 投稿者
    投稿
  • #44840

    suzukiakiyo
    参加者

    ●バージョン lightning pro 8.1.0

    ●質問
    こちらで質問することではないのかしれないのですが失礼します。

    ブラウザによって、画像が表示されないものがあります。
    画像のように、グーグルクロームでは表示されているのにエッジだと表示されないといった現象が起こっています。
    よくあることなのでしょうか?
    制作時の設定の仕方などは関係ないとは思うのですが、いかがでしょうか。

    Attachments:
    You must be logged in to view attached files.
    #44844

    ls-t
    参加者

    ChromeやEdgeのキャッシュを削除してから再読み込みしても改善されないようでしたら、以下の項目をご確認ください。

    ・画像の指定(imgタグで指定しているパス)は正しいか
    ・画像の拡張子は正しいか
    ・ファイル名に2バイト文字(日本語、全角アルファベットなど)が使用されていないか

    サポートしていない拡張子だったり、ファイル名に全角文字が使われていたりするとブラウザによっては表示出来ないことがあります。

    #44845

    石川@Vektor,Inc.
    キーマスター

    画像のURLがhttpで保存されているかもしれないので、
    削除して保存して、再度登録して保存してみてください。

    #44846

    suzukiakiyo
    参加者

    ありがとうございます。

    日本語で画像のファイル名を付けていました・・・
    画像を選択する画面で、代替テキストとタイトルは英語でないといけなくて、
    画像自体のファイル名も英語で付けてあげるのが前提ということですね。

    画像のURLがhttpで保存されているかもしれないので、
    削除して保存して、再度登録して保存してみてください。
    → これはどこで確認できますか?

    #44847

    ls-t
    参加者

    画像自体のファイル名が1バイト文字(半角のアルファベット(小文字推奨)、半角数字など)であれば基本的には問題ありません。
    メディアライブラリの画像詳細ページで記入出来る代替テキストとタイトルについては日本語でも大丈夫です。
    各項目の詳細については以下のURLが詳しいので、もし気になるようでしたらご一読ください。

    メディアライブラリ画面

    画像のURLについてもメディアライブラリの画像詳細ページで確認出来ます。
    代替テキスト、タイトル、キャプションなどの下にある「ファイルのURL」という項目がその画像ファイルのURLです。
    この画面から直接URLを変更することは出来ないので、石川さんのご指示通り一度画像を削除して再度アップロードした後に、改めて画像を挿入するのが確実かと思います。

    #44853

    石川@Vektor,Inc.
    キーマスター

    ヘッダーのロゴは 外観 > カスタマイズ > Lightning デザイン設定 からの指定ですので、
    削除して保存し、改めて選択してください。

    > ls-t さん

    回答ありがとうございます!!!!!!

    #44854

    石川@Vektor,Inc.
    キーマスター

    ※解決してベストアンサーをつけるは「キーマスター」「モデレーター」以外につけてください。

    #44863

    suzukiakiyo
    参加者

    ありがとうございます。

    画像を一度削除して登録しなおしたら、どのブラウザでも表示されるようにはなりました!

    ですが、ファイルのURLには、https:~ と書かれているままです。
    これは特に問題はないのですか?

    #44864

    石川@Vektor,Inc.
    キーマスター

    問題ありません。

    もとが http で過去に保存されていたために、サイトのURLはhttpsなのに非sslのhttpの画像を読み込もうとしたために、ブラウザ側が「そんな暗号化通信されてないもの表示させへんでー」という状態だったのだと思います。たぶん。

    なので,一度削除して、登録しなおした事で https になったために問題なくなった状態です。

    #44865

    suzukiakiyo
    参加者

    そうなのですね!
    承知しました。
    助かりました、ありがとうございました。

10件の投稿を表示中 - 1 - 10件目 (全10件中)
  • このトピックに返信するにはログインが必要です。