VWSとは フォーラム Lightning [ 解決済 ] Varietyを更新をしましたらエラーになりました。

[ 解決済 ] Varietyを更新をしましたらエラーになりました。

タグ: 

  • このトピックには12件の返信、3人の参加者があり、最後にVektor,Incにより2週前に更新されました。
13件の投稿を表示中 - 1 - 13件目 (全13件中)
  • 投稿者
    投稿
  • #29540

    yashu_ka
    参加者

    サイトに重大なエラーがありました。

    WordPress でのデバッグをさらに詳しく見る。

    ページに上記2行のみ表示され、なにもできません。
    2行目には、リンクが下記のページが貼られおります。

    Debugging in WordPress

    #29542

    yashu_ka
    参加者

    追記します。

    WPから届きましたメールに以下の内容です。

    エラー詳細
    ===============
    エラータイプ E_ERROR が /home/users/0/noor.jp-protoxrd/web/wp-content/plugins/lightning-skin-variety/inc/plugin-update-checker/Puc/v4/Factory.php ファイルの 4 行目で発生しました。 エラーメッセージ: Uncaught Error: Class ‘Puc_v4p7_Factory’ not found in /home/users/0/noor.jp-protoxrd/web/wp-content/plugins/lightning-skin-variety/inc/plugin-update-checker/Puc/v4/Factory.php:4
    Stack trace:
    #0 /home/users/0/noor.jp-protoxrd/web/wp-content/plugins/lightning-skin-variety/inc/plugin-update-checker/plugin-update-checker.php(11): require()
    #1 /home/users/0/noor.jp-protoxrd/web/wp-content/plugins/lightning-skin-variety/lightning_skin_variety.php(45): require(‘/home/users/0/n…’)
    #2 /home/users/0/noor.jp-protoxrd/web/wp-settings.php(360): include_once(‘/home/users/0/n…’)
    #3 /home/users/0/noor.jp-protoxrd/web/wp-config.php(94): require_once(‘/home/users/0/n…’)
    #4 /home/users/0/noor.jp-protoxrd/web/wp-load.php(37): require_once(‘/home/users/0/n…’)
    #5 /home/users/0/noor.jp-protoxrd/web/wp-admin/admin.php(34): require_once(‘/home/users/0/n…’)
    #6 /home/users/0/noor.jp-protoxrd/web/wp-admin/update-core.php(10): require_once(‘/home/users/0/n…’)
    #7 {main}
    thrown

    #29544

    Vektor,Inc
    キーマスター

    まずは通知メールにリカバリーモードでのログイン案内があるかと思いますが、リカバリーモードでログインできますか?
    リカバリーモードでログイン出来るようでしたらログインして一旦Varietyを停止してみてください。

    ご利用のサーバーのPHPのバージョンはいくつでしょうか?

    #29547

    yashu_ka
    参加者

    ご返信、ご協力ありがとうございます。

    WPから先の内容と共に下記の内容もメールにありましたので、共有させて頂きます。

    この問題を解決しようとする際、以下の情報を聞かれるかもしれません。
    WordPress バーション5.3.2
    現在のテーマ: Lightning Pro Child Sample (バージョン 0.0.0)
    現在のプラグイン: Lightning Skin Variety (バージョン 6.0.0) PHP バージョン7.3.10

    リカバリーモードでログインできました。
    且つ、ご指示通り、Varietyを停止しましたが、
    リカバリーモードは終了させて良いのでしょうか?

    再度、宜しくお願い致します。

    #29553

    yashu_ka
    参加者

    ログを長くしてすみません。

    iPadから該当のサイトを、表示出来るかを確認しましたら、表示することが出来ています。

    多分ですが、リカバリーモードは終了させて良いと推測しますが、
    その後、Varietyはどういたしましょうか?

    ご教授願います。

    #29562

    Vektor,Inc
    キーマスター

    Varietyを一旦停止した状態であればリカバリーモードは終了してかまいません。
    エラーについては現在症状を調査中です。
    ご迷惑おかけして恐れ入りますが今しばらくお待ちくださいませ。

    #29563

    yashu_ka
    参加者

    ご継続のお知らせ、ありがとうございます。

    当方、ウェブは幸いにもきちんと表示出来ておりますので、問題ありませんが、
    今後の対応のみして頂ければと思います。

    何卒宜しくお願い致します。

    #29565

    DRILL LANCER
    参加者

    マイアカウント > ダウンロードから最新版の Lightning Skin Variety がダウンロード可能になったようなので、Lightning Skin Variety を一旦削除して最新版をインストールしてみてください。

    ※ちなみに私は外部の一般人です。

    #29567

    Vektor,Inc
    キーマスター

    ご迷惑おかけして大変恐れ入ります。

    利用していたアップデートモジュールをバージョンアップした Variety 6.0.1 をアップいたしました。

    お手数ですがVWSのマイアカウントページよりダウンロードしてください。
    https://vws.vektor-inc.co.jp/my-account/downloads

    今のVarietyを有効化するとまたエラーになるかもしれませんので、一旦削除して、
    ダウンロードしたVarietyをアップロードして有効化してください。

    その上で、もし余力があれば以下ご協力いただけると助かります。

      1. プラグイン > プラグインエディター を開く
      2. 画面右上のプルダウン「編集するプラグインを選択:」で Lightning Skin Variety を選択
      3. 6行目あたりに version の記載があります。ここを 3.0.0 など古い数字に変更して、編集エリア下の「ファイルを更新」をクリック
      4. これでおそらくアップデート通知が出るのでアップデートを実行
      5. エラーにならないか確認

    以上よろしくお願いいたします。

    • この返信は2週前にVektor,Incが編集しました。
    • この返信は2週前にVektor,Incが編集しました。
    #29618

    yashu_ka
    参加者

    解決しました。
    ありがとうございました。

    #29619

    yashu_ka
    参加者

    大きなことでは無いのですが…。

    Lightning Skin Varietyを何度更新しても、画面左のメニューにあります「プラグイン」の右に表示される更新を表す数字が消えません。

    #29620

    DRILL LANCER
    参加者

    Lightning Skin Variety を 6.0.3 に更新しても lightning_skin_variety.php に記載されているバージョン情報が 6.0.2 であるため無限ループが発生しているようです。

    #29621

    Vektor,Inc
    キーマスター

    失礼いたしました。アップしなおしましたのでご確認くださいませ。
    度々お手数おかけして恐れ入りますがよろしくお願いいたします。

13件の投稿を表示中 - 1 - 13件目 (全13件中)
  • このトピックに返信するにはログインが必要です。