[ 解決済 ] VK Blocks Proの1.0.16➡1.1.0でサイトに重大なエラー

VWSとは フォーラム VK Blocks・Pro [ 解決済 ] VK Blocks Proの1.0.16➡1.1.0でサイトに重大なエラー

[ 解決済 ] VK Blocks Proの1.0.16➡1.1.0でサイトに重大なエラー

4件の投稿を表示中 - 1 - 4件目 (全4件中)
  • 投稿者
    投稿
  • #50333

    これはプラグインの不具合と言うより、当方のPHP環境が古いための問題だと思うのですが、
    1.0.16では表示されていたサイトが、1.1.0で表示されなくなりました。
    「このサイトに重大なエラーが生じています。」という表示になります。
    なにせ、PHPが7.1.33…システム更新を先送りにしてきた自分のせいだから、
    何とかしてという要望は出すつもりはないのですが、
    1.0.16がサイトからダウンロードできる状態であればうれしいかなと思います。
    現在はとりあえずJetpackのバックアップから1.0.16を復活させて回復させています。

    他の環境は
    Lightning Pro バージョン: 8.9.4
    Lightning Skin Fort バージョン 9.1.0
    Lightning Advanced Slider バージョン 0.6.0

    ちなみにApacheのログを見ると、こんな感じです。
    PHP Fatal error: Uncaught Error: Call to undefined method VK_Swiper::swiper_paras_json() in /Users/user/Site/wp-content/plugins/lightning-advanced-slider/inc/top-slide/top-slide.php:68

    1.0.16だとこのエラーは出ません。


    該当URL : https://*********

    ※該当URLはフォーラムライセンスが有効のユーザーにのみ表示されます

    #50337

    対馬 俊彦
    参加者

    プラグイン Lightning Advanced Slider が原因ですので、
    このプラグインを無効化すれば解決すると思いますし、
    VK Blocks Pro 1.1.0 にアップデートしてもエラーが起きなくなります。

    現在の Lightning は Lightning Advanced Slider が不要ですので、
    Lightning Advanced Slider を削除しても問題ありません。

    #50397

    ご教授通り、Lightning Advanced Sliderを無効化したところ、1.1.0にしてもエラーが出ませんでした。
    ありがとうございます。

    ところで、これはVektorさんに要望ですが、
    うちはWeb屋ではなく、末端の利用者に過ぎないので、
    ずっとVektorさんの動向を注視しているわけではありません。
    最近はプラグインにしても自動更新だから、
    結果こういうことになるわけですが…

    プラグインによっては、ダッシュボード上部にアラート出したりするのがありますよね。

    ダッシュボードなら集客状況などサイトのチェック等で常に見るので、
    Lightning Advanced Sliderのように、時限的に使ったプラグインについては、
    もういらないとなった時点でもう一つ更新して、
    「Lightning Advanced SliderはLightning本体に取り込まれたので、無効化・削除をしてください」
    とか表示してくれると、
    よりみんながしあわせになれると思いますが、いかがですか?

    #50402

    石川@Vektor,Inc.
    キーマスター

    > 「Lightning Advanced SliderはLightning本体に取り込まれたので、無効化・削除をしてください」
    とか表示してくれると、

    はい、おっしゃるとおりです。
    次回のアップデートにて板王させていただきます。

4件の投稿を表示中 - 1 - 4件目 (全4件中)
  • このトピックに返信するにはログインが必要です。