[ 対応待ち ] プラグインインストールエラー:VK All in One Expansion Unit_VK Block Patterns

VWSとは フォーラム Lightning [ 対応待ち ] プラグインインストールエラー:VK All in One Expansion Unit_VK Block Patterns

[ 対応待ち ] プラグインインストールエラー:VK All in One Expansion Unit_VK Block Patterns

  • このトピックには11件の返信、2人の参加者があり、最後にkeiichiooharaにより2年前に更新されました。
12件の投稿を表示中 - 1 - 12件目 (全12件中)
  • 投稿者
    投稿
  • #62473

    keiichioohara
    参加者

    ■ WordPress のバージョン
    5.9.1

    ■ テーマ・プラグインは全て最新版で確認してください。
    確認しました。

    ■ 子テーマをご利用の場合は親テーマに変更して症状が改善するか確認してください。
    確認しました。

    ■ テーマの種類
    Lightning ( G3 ) + Lightning G3 Pro Unit

    ■ テーマのバージョン
    14.17.1

    ■ Pro Unit のバージョン
    0.17.0

    ■ スキンの種類
    Origin III

    ■ 関連しそうなプラグインを一つづつ停止して症状が改善するか確認してください。
    確認しました。

    ■ プラグインの種類・バージョン
    VK All in One Expansion Unit バージョン 9.71.1.1
    VK Block Patterns バージョン 1.13.3

    ■ 期待する動作
    2つのプラグインをぜひ使いたいと考えてます。サーバはオンプレミスでOSはArch Linuxを使用しています。Linuxでプラグインインストールで問題がないディストリビューションがあればそちらに切り替えますので,情報があれば教えてください。

    ■ 自分で試した事
    プラグインを一つずつインストールしようとしましたが,エラーがでましたので,サーバサイドでプラグインファイルを削除しています。phpなどの変更は一切行っていません。2つのプラグインなしでLightning G3 Pro Packでサイト構築しています。

    ■ 症状が発生するブラウザ
    chrome

    ■ 実際の症状
    「このサイトで重大なエラーが発生しました。対応手順については、サイト管理者のメール受信ボックスを確認してください。」のメッセージができます。

    ■ その他特記事項
    まだ,イントラサーバで試験運用中であるため,該当URLを指定できません。

    #62476

    石川@Vektor,Inc.
    キーマスター

    他のプラグインはインストール出来る状態なのでしょうか?

    なんとなくサーバー固有の問題にも思えますので、公式ディレクトリからzipでダウンロードして直接 wp-content/plugins ディレクトリにアップロードで有効化はできますか?

    #62485

    keiichioohara
    参加者

    早速のご連絡ありがとうございました。

    >他のプラグインはインストール出来る状態なのでしょうか?

    できます。

    >なんとなくサーバー固有の問題にも思えますので、公式ディレクトリからzipでダウンロードして直接 wp-content/plugins ディレクトリにアップロードで有効化はできますか?

    こちらについてはやっていませんでした。
    対応にすこし時間がかかるので,結果がでましたら,ご連絡させて頂きます。

    #62486

    石川@Vektor,Inc.
    キーマスター

    管理画面の上部に表示されるインストーラーからの処理がサーバーによって弾かれているのかもしれません。

    他のプラグインと同様に、プラグイン -> 新規追加 でプラグイン名を入力して、そこからインストールできませんか?

    一度お試しいただいてまた状況返信くださいませ。

    #62541

    keiichioohara
    参加者

    石川様

    >他のプラグインと同様に、プラグイン -> 新規追加 でプラグイン名を入力して、そこからインストールできませんか?
    >一度お試しいただいてまた状況返信くださいませ。

    この方法で

    VK All in One Expansion Unit

    は無事インストールできました。

    しかし,VK Block Patternsの方は,やはり以下のメッセージがでました。

    このサイトで重大なエラーが発生しました。対応手順については、サイト管理者のメール受信ボックスを確認してください。
    WordPress のトラブルシューティングについてはこちらをご覧ください。

    できれば管理画面で処理したいのでご対応お願いします。

    #62542

    石川@Vektor,Inc.
    キーマスター

    サーバーのPHPのバージョンはいくつでしょうか? ( 動作条件は 7.2 〜 です )

    #62545

    keiichioohara
    参加者

    >サーバーのPHPのバージョンはいくつでしょうか? ( 動作条件は 7.2 〜 です )
    7.2.24です。

    #62562

    石川@Vektor,Inc.
    キーマスター

    wp-config.php で デバッグモードを true にしてどんなメッセージが出るか確認してください。

    https://gatespace.jp/2012/07/20/wordpress-debugging/

    #62617

    keiichioohara
    参加者

    ご連絡ありがとうございました。

    >wp-config.php で デバッグモードを true にしてどんなメッセージが出るか確認してください。

    こちら作業に取り掛かるためには少し時間がかかります。
    結果がわかりましたら、連絡させていただきます。

    お手数をおかけします。

    #62668

    keiichioohara
    参加者

    >wp-config.php で デバッグモードを true にしてどんなメッセージが出るか確認してください。

    サイトを表示すると以下のエラー表示となりました。

    > Fatal error: Uncaught Error: Call to undefined function mb_strtolower() in /var/www/html/fb/wp-content/plugins/vk-all-in-one-expansion-unit/inc/display-ie-alert.php:12 Stack trace: #0 /var/www/html/fb/wp-content/plugins/vk-all-in-one-expansion-unit/inc/display-ie-alert.php(51): veu_is_ie() #1 /var/www/html/fb/wp-includes/class-wp-hook.php(307): veu_insert_alert(”) #2 /var/www/html/fb/wp-includes/class-wp-hook.php(331): WP_Hook->apply_filters(NULL, Array) #3 /var/www/html/fb/wp-includes/plugin.php(474): WP_Hook->do_action(Array) #4 /var/www/html/fb/wp-includes/general-template.php(3074): do_action(‘wp_body_open’) #5 /var/www/html/fb/wp-content/themes/lightning/_g3/header.php(19): wp_body_open() #6 /var/www/html/fb/wp-includes/template.php(772): require(‘/var/www/html/f…’) #7 /var/www/html/fb/wp-content/themes/lightning/functions.php(137): load_template(‘/var/www/html/f…’, false) #8 /var/www/html/fb/wp-content/themes/lightning/_g3/index.php(12): lightning_get_template_part(‘header’) #9 /var/www/html/fb/wp-includes/temp in /var/www/html/fb/wp-content/plugins/vk-all-in-one-expansion-unit/inc/display-ie-alert.php on line 12

    > Call to undefined function mb_strtolower()
    と存在しない関数との表示だったので、yum install php-mbstring したところ、
    復旧しているようです。

    この対処でよろしいでしょうか?

    #62673

    石川@Vektor,Inc.
    キーマスター

    はい、その対応で問題ありません。

    サーバーによって mb_strtolower() でエラーにならないように ExUnit / VK Block Patterns 側も対応させていただきます。

    ご報告ありがとうございます。

    https://github.com/vektor-inc/vk-all-in-one-expansion-unit/issues/786

    #62675

    keiichioohara
    参加者

    ご連絡ありがとうございました。
    迅速なご対応ありがとうございました。

12件の投稿を表示中 - 1 - 12件目 (全12件中)
  • このトピックに返信するにはログインが必要です。