[ 解決済 ] プラグインが動きません

VWSとは フォーラム バグ報告と提案 [ 解決済 ] プラグインが動きません

[ 解決済 ] プラグインが動きません

8件の投稿を表示中 - 1 - 8件目 (全8件中)
  • 投稿者
    投稿
  • #54592

    NaotakaSaito
    参加者

    ■ 症状が発生するブラウザ :
    Google chrome
    ■ 利用テーマとバージョン :
    Lightning Pro
    ■ 質問内容:
    1) Lightning-proを導入しました。推奨されるvk-all-in-one-expansion-unitとvk-block-patternsをインストールすると、「このサイトで重大なエラーが発生しました。」と表示されます。そして、/var/log/apache2/error.logにはこのようなエラーが表示されます。

    [Sun Aug 01 23:54:13.537449 2021] [php7:error] [pid 5034] [client 172.31.34.217:25828] PHP Fatal error: Uncaught Error: Call to undefined function wp_content\\plugins\\vk_block_patterns\\patterns_data\\mb_convert_encoding() in /var/www/html/wp-content/plugins/vk-block-patterns/patterns-data/class-register-patterns-from-json.php:57\nStack trace:\n#0 /var/www/html/wp-includes/class-wp-hook.php(303): wp_content\\plugins\\vk_block_patterns\\patterns_data\\VK_RegisterPatternsFromJson::register_template()\n#1 /var/www/html/wp-includes/class-wp-hook.php(327): WP_Hook->apply_filters()\n#2 /var/www/html/wp-includes/plugin.php(470): WP_Hook->do_action()\n#3 /var/www/html/wp-settings.php(578): do_action()\n#4 /var/www/html/wp-config.php(117): require_once(‘/var/www/html/w…’)\n#5 /var/www/html/wp-load.php(50): require_once(‘/var/www/html/w…’)\n#6 /var/www/html/wp-blog-header.php(13): require_once(‘/var/www/html/w…’)\n#7 /var/www/html/index.php(17): require(‘/var/www/html/w…’)\n#8 {main}\n thrown in /var/www/html/wp-content/plugins/vk-block-patterns/patterns-data/class-register-patterns-from-json.php on line 57

    2) Lightning-proと一緒に「Lightning G3 Pro Unit」をインストールしたのですが、
    「Lightning G3 Pro Unit は テーマが Lightning のときのみ動作します。 Lightning をインストールし有効化してください。」と表示されます。

    #54593

    Lightningのご利用ありがとうございます。株式会社ベクトルの石川と申します。

    まず 1 に関しては

    * WordPressのバージョン
    * PHPのバージョン

    はいくつでしょうか?

    2 に関しては

    「Lightning G3 Pro Unit は テーマが Lightning のときのみ動作します。 Lightning をインストールし有効化してください。」と表示されます。

    記載の通り、Lightning G3 Pro Unit は テーマが Lightning のときのみ動作します。 Lightning をインストールし有効化してください。

    Lightning Pro よりも Lightning + Lightning G3 Pro Unit を組み合わせて使う方が新しいので、 G3 Pro Unit を使うのであれば Lightning Pro は不要です。

    HOME

    ※複数の質問を一つのトピックで行うとどこまで解決済みかわからなくなるので、以後質問一つにつき一つのトピックでよろしくお願いいたします。

    #54600

    NaotakaSaito
    参加者

    早速のご返信ありがとうございます。

    プラグインが動作しない件、Wordpressは最新の5.8、PHPは7.4を利用しています。

    #54628

    現状弊社環境で 1 で報告いただいているエラーは発生しないのですが、
    とりあえず Lightning Pro でないといけない理由はありますか?

    Lightning(無料版) + G3 Pro Unit の組み合わせの方が新型なのでお勧めですが、
    その組み合わせなら正常に有効化できると思いますが如何でしょうか?

    #54629

    サーバーにマルチバイトを扱うライブラリが入っていない事が原因だと思われます。

    https://ao-system.net/note/90
    https://loumo.jp/archives/21099

    #54631

    1 の件 mb_convert_encoding() が使えないサーバーでもエラーにならないように VK Block Patterns の方を変更いたしました。

    改めてご確認くださいませ。

    お手数おかけして恐れ入りますがよろしくお願いいたします。

    #54643

    NaotakaSaito
    参加者

    ありがとうございます。
    ・phpにmb_convert_encodingを追加
    ・WP Multibyte Patchのプラグインを追加
    をしてからインストールしたら、解決しました。
    なお、導入後はこのようなエラーが出るようになりましたが、作業には支障がないので先に進めます。ありがとうございました。
    Failed to load resource: the server responded with a status of 404 ()
    https://www.appliot.co.jp/index.php/wp-json/vk_ex_unit/v1/hatena_entry/xxxxxxxxx

    • この返信は1ヶ月、 3週前にNaotakaSaitoが編集しました。
    #54659

    Failed to load resource: the server responded with a status of 404

    ExUnit > メイン設定 > SNS の 投稿数 を POST にすると表示されなくなると思います。
    よろしくお願いいたします。

8件の投稿を表示中 - 1 - 8件目 (全8件中)
  • このトピックに返信するにはログインが必要です。